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1 Introduction 

CADS Revit SCIA Engineer link facilitates the bi-directional exchange of members, loads and supports 
between Autodesk Revit and SCIA Engineer and in doing so plays a vital role in the overall Building 
Information Modelling (BIM) process. A structure modelled in Revit can be transferred to SCIA 
Engineer for structural analysis and design using CADS Revit SCIA Engineer link. When the structural 
analysis and design has been completed in SCIA Engineer, the updated model can be sent back to 
Revit. The modelling - analysis - design process requires numerous iterations to arrive at the final 
design. CADS Revit SCIA Engineer link will save time by avoiding duplication and reducing errors.  

This Getting Started guide will help you with instructions on how to install the software and make the 
best use of CADS Revit SCIA Engineer link to manage your BIM process successfully. 

The Content libraries in Revit are stored as a collection of the Revit family (*.RFA) files. Please 
ensure that the country specific libraries are installed on the system while installing Revit. 

 

  
Figure 1-1: Revit installation option 
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2 Compatibility 

CADS Revit SCIA Engineer link is shipped with a Release Notes document which lists the versions of 
Revit and SCIA Engineer with which it is compatible. You can also find this document in the following 
folder: 
 
C:\Program Files\Revit To SCIA Engineer\Revit20xx\Docs 
 
C:\Program Files folder is the default installation folder for CADS Revit SCIA Engineer Link.  
 

 
Figure 2-1: CADS Revit SCIA Engineer Link installation folder 

Revit20xx is the Revit version number on which CADS Revit SCIA Engineer link is installed. 
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3 Workflow 

CADS Revit SCIA Engineer link supports the following workflows:  

3.1 Revit to SCIA Engineer round trip 

 
Figure 3-1: Revit to SCIA Engineer round trip 

3.2 SCIA Engineer to Revit round trip 

 
Figure 3-2: SCIA Engineer to Revit round trip  
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4 Installation 

This section sets out how to install CADS Revit SCIA Engineer link on various system environments. 

If you wish to have a direct link between Revit and SCIA Engineer, you should have both 
applications installed and licensed on your system. 

If only one of the applications is licensed (i.e. Revit or SCIA Engineer) and you wish to share your model 
with your colleague then you need to use the file based transfer method. This means, you will have to 
create a *.R2S file from either of the applications and then import it into the other application.  

ESA RevitLink (ESA.21) module should be licensed as part of the SCIA Engineer installation to exchange 
models in between Revit and SCIA Engineer. 

 
Figure 4-1: SCIA Engineer - Protection setup dialog 

Note: 

We suggest that you uninstall the previous version of CADS Revit SCIA Engineer link before starting 
the installation of the latest version of CADS Revit SCIA Engineer link.  

The mapping databases is updated in the latest version of CADS Revit SCIA Engineer link (2019.0). If 
you wish to use any of the existing databases or any pre-defined customised databases, you can import 
the user databases using the import database option in mapping tables or you copy them into the 
folder C:\ProgramData\CADS\Revit to SCIA Engineer\Revit 20xx\Mapping Databases.  

4.1 Revit and SCIA Engineer licensed on the system 

 Check in the Release Notes whether the Revit version is compatible with the version of CADS 
Revit SCIA Engineer link you wish to install on your system. If yes, then continue with the 
installation, or else install the required version of either Revit or SCIA Engineer. 

 Run CADS Revit SCIA Engineer link installation and select the options as prompted in the 
dialogs. 

 Finish the installation. 
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4.2 Only Revit licensed on your system 

 Check in the Release Notes whether the Revit version is compatible with the version of CADS 
Revit SCIA Engineer link you wish to install on your system. If yes, then continue with the 
installation or else install the required version of Revit. 

 Run CADS Revit SCIA Engineer link installation and select the options as prompted in the 
dialogs. 

4.3 Only SCIA Engineer licensed on your system 

CADS Revit SCIA Engineer link installation is not required. As long as you have the ESA RevitLink 
(ESA.21) module installed and licensed on your system you can export or import the *.R2S file from 
SCIA Engineer as explained in Section 5. 
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5 Basic commands 

In order to transfer the model from Revit to SCIA Engineer, you must specify the following: 

5.1 Code of practice 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Options -> National Code 

 
Figure 5-1: CADS Revit SCIA Engineer Link - National Code  

Select the National Design Code you wish to use in SCIA Engineer before exporting the mode from 
Revit. CADS Revit SCIA Engineer Link will automatically select the appropriate SCIA Engineer template 
to create the model. 

The first time you import a project from SCIA Engineer into Revit, ensure that you create a new Revit 
file and select the correct template file as per the country code used for creating the job in SCIA 
Engineer. 

Revit -> New -> Project 
 

 
Figure 5-2: Revit - New project dialog  

Use the Browse button to locate the correct template file.  



Revit SCIA Engineer link - Getting Started 

7 
 Copyright © Computer and Design Services Limited 

 
Figure 5-3: Revit - Choose template dialog  

You may choose any customised Revit Structural template file as well, but make sure that the 
units are the same as those used in the SCIA Engineer model. For example, if the SCIA Engineer model 
is created in Metric units, then the Revit Structural template should also be in Metric. 

Ensure that the Revit libraries of structural members are available in the default Revit installation 
folder, for example the library of UK cross sections are available in the following folder for Revit 2018 
by default. 

..\ProgramData\Autodesk\RVT 2020\Libraries\UK 

 
Figure 5-4: Revit - Family folder  

If you are using the library of customised Revit families and/or the library of Revit families stored in 
LAN, you have to configure the folder location where these Revit families are stored. 

You can access this from: 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Options -> Mapping Details -> Revit Family Path 
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Figure 5-5: CADS Revit SCIA Engineer Link - Revit family path  

5.2 Mode of Export 

There are two ways in which a model can be exchanged between Revit and SCIA Engineer: 

 Direct exchange method: In this method the model is transferred directly between Revit and 
SCIA Engineer without the need of any data exchange file. You must have both Revit and SCIA 
Engineer licensed on your system to use this method of model exchange.  

 R2S file exchange method: If you have either Revit or SCIA Engineer licensed on your system 
then you can exchange modes using a data exchange file in the *.R2S format. 

Should you wish to transfer a model using the Direct exchange method, you should set the option 
Mode of Export to Direct Exchange.  
 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Options -> Actions -> Mode of Export 

 
Figure 5-6: CADS Revit SCIA Engineer Link - Launch SCIA Engineer  
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The matrix below shows how the CADS Revit SCIA Engineer Link works when you use the export or 
import feature from Revit or SCIA Engineer. 

 Revit  SCIA Engineer 

Export Import Export Import 

Mode of 
Export  = 
Direct 
Exchange 

Invokes SCIA Engineer 
automatically with the same 
file name and folder location 
as that of a Revit Structure 
job. 

Imports the SCIA Engineer 
job into Revit # 

Prompts you to 
specify the file name 
for the *.R2S file you 
wish to create which 
can be imported into 
Revit. 

Prompts you to 
select the *.R2S file 
you created / 
modified from Revit. 

Mode of 
Export  = 
File  
Exchange  

Prompts you to specify the 
file name for the *.R2S file 
you wish to create which can 
be imported into SCIA 
Engineer. 

Prompts you to select the 
*.R2S file you 
created/modified in SCIA 
Engineer. 

 

Figure 5-7: Model export & import matrix  

#Owing to certain programming API limitations, while importing the job into Revit you might get an 
error message ‘Unable to find SCIA Engineer model’. In such cases, please follow the following steps: 

1. Save the job in SCIA Engineer 

2. Close SCIA Engineer 

3. Open Revit  

4. Create a new job with Structural template 

5. Save the new job with a dummy Revit file name, e.g. Test.rvt 

6. Export the job to SCIA Engineer with Mode of Export as “Direct Exchange” 

7. A new session of SCIA Engineer will be created. Open the original job (point 1) in this session of 

SCIA Engineer 

8. Now import the SCIA Engineer job into Revit  

5.3 Version of SCIA Engineer 

You will have to select the SCIA Engineer version you wish to use for export/import of models. 
 

Revit  -> CADS -> CADS Revit SCIA Engineer Link -> Options -> Actions -> SCIA Engineer Version -> 
Browse -> Add 
 

 
Figure 5-8: CADS Revit SCIA Engineer Link - Options button  
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Figure 5-9: CADS Revit SCIA Engineer Link - Add SCIA Engineer version dialog  

Click on the Add button to select the SCIA Engineer root folder as shown below: 

 
Figure 5-10: CADS Revit to SCIA Engineer Link - Browse for SCIA Engineer folder  

Select OK and then Close the previous dialog. 

5.4 Case 1: Export from Revit to SCIA Engineer 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Export 

You can export the structural model in Revit to SCIA Engineer using the Export / Review & Export 
option.  

 
Figure 5-11: CADS Revit SCIA Engineer Link – Export  
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CADS Revit SCIA Engineer Link application will read the Revit model, and prepares the list of the total 
number of elements from each category that is to be exported. The application then exports the Revit 
model into SCIA Engineer based on the stings listed in “Options” dialog. 

On completion of the export routine, the Log dialog shows a summary of the number of items 
exported. You can save a log file which can be opened in a text editor to review the transfer. Please 
save the Revit model once the export is completed in order to enable the review manager to track the 
changes for subsequent export. 

After export, for any reason, you make some changes to the Revit model and export it to SCIA Engineer 
and you may want to review the changes to the model. In this case you may choose the Review & 
Export option which updates the SCIA Engineer model. 

 
Figure 5-22: CADS Revit SCIA Engineer Link - Export model from Revit to SCIA Engineer  

Using the Review & Export option, the application will open the review manager that will list the 
changes to export by comparing the current Revit model with the last exported model. Please refer to 
the Help document for more details on this feature.  

CADS Revit SCIA Engineer Link will open an instance of SCIA Engineer and create a SCIA Engineer model 
with the same file name as that of Revit. You may either choose to create a new SCIA Engineer file or 
overwrite an existing one by setting the following option. 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Options -> Export to SCIA Engineer -> Create New 

 
Figure 5-133: CADS Revit SCIA Engineer Link - Create new SCIA Engineer file  

When the option Create New is un-ticked, only the changes in the model will be updated to the existing 
SCIA Engineer file. Where the model is being transferred for the first time then CADS Revit SCIA 
Engineer Link will automatically create a new SCIA Engineer file (*.ESA) with the model. 

If the option Create New is ticked, CADS Revit SCIA Engineer Link will overwrite the entire model 
information in the SCIA Engineer file. If an existing SCIA Engineer file with the same name is available 
then the old data in the file will be completely replaced by the new model data.  

 If you already have a SCIA Engineer session open in your system then CADS Revit SCIA Engineer 
Link may open another session owing to certain programming limitations.   

For the File exchange method of model exchange, the *.R2S file generated from Revit can be imported 
into SCIA Engineer using the Import or Update option. 

SCIA Engineer -> File -> Import -> Revit File 
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Figure 5-14: SCIA Engineer - Import Revit file  

The Import option will create a new SCIA Engineer file and add the model information to it. 

SCIA Engineer -> File -> Update -> Revit File 

 
Figure 5-154: SCIA Engineer - Update Revit file  

The Update option will update only the changes to an existing SCIA Engineer file. 

5.5 Case 2: Import from SCIA Engineer to Revit  

Revit -> CADS -> Revit SCIA Engineer Link -> Import 

 
Figure 5-16: CADS Revit SCIA Engineer Link - Import model from SCIA Engineer to Revit Structure  

You can import a SCIA Engineer model into Revit Structure using the Review & Import / Import option.  
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Click on Review & Import to track the changes between the SCIA Engineer model and the current Revit 
model. 

 
Figure 5-17: CADS Revit SCIA Engineer Link – Review & Import – Model Preview  

Please refer to the Help document for more details on this feature. 

First, set the standard Code of Practice and ensure the cross section library is mapped correctly before 
starting the import as detailed in Section 5.1 Code of practice. 

You may import the model into Revit from SCIA Engineer using the *.R2S file too. 

 In both cases, you can use the Select Changes option to highlight the new or updated elements. 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Options -> Select Imported 

 
Figure 5-18: CADS Revit SCIA Engineer Link - Select changes  

For the R2S file exchange method, you will have to first create a *.R2S file from SCIA Engineer using 
the following option: 

SCIA Engineer -> File -> Export -> Revit File 
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Figure 5-19: SCIA Engineer - Export Revit file  

5.6 Mapping tables 

The standard cross section and material libraries in both Revit and SCIA Engineer are comprehensive 
but are labelled differently. Therefore, CADS Revit SCIA Engineer link is shipped with a pre-installed 
mapping databases which matches materials, cross-sections and profile sheets between SCIA Engineer 
and Revit.  

In many cases, the users may require to use custom families in addition to the standard families. In 
such cases, the pre-defined database which contains the entries of standard material mapping or the 
section mapping is not enough to transfer the data between Revit and SCIA Engineer. Hence it is 
necessary to have user mapping to map the custom Revit families with equivalent SCIA Engineer 
materials/ sections.   

The “Mapping Tables” command will allow the user to create their own database for custom family 
mapping. On the first use of CADS Revit SCIA Engineer Link the user table will be blank. The application 
will allow the user to add/create new entries for any new family (cross section) / material / profile 
sheet. 

 
Figure 5-4: CADS Revit SCIA Engineer Link - Mapping tables  

The application will also allows the user to save and export the mapping database and this file can be 
shared across the users. The “Import” option will allow the user to load any database into the project 
and use them during export/import. For more details on mapping tables, please refer to the help 
document. 
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6 Features 

Structural elements present in Revit or SCIA Engineer can be exchanged between the two applications, 
provided both the products support them. For example, you can apply a Moment in node in SCIA 
Engineer but there is no equivalent feature in Revit, hence it will be ignored when you import a model 
into Revit from SCIA Engineer. 

Similarly, structural properties may be known by different names, but are mapped based on their role. 
For example, the ‘line support’, known as Boundary Condition – Line in Revit is equivalent to Support 
- Line on Beam or Support – Line on 2D Member in SCIA Engineer. 

A complete list of features supported is available in the Help file. 

Revit -> CADS -> CADS Revit SCIA Engineer Link -> Help -> Introduction -> Bi Directional Link 
between Revit and SCIA Engineer 

 
Figure 6-1: CADS Revit SCIA Engineer Link - Help button  

All structural elements present in a Revit project will be exported to SCIA Engineer if the configuration 
option Export Selected Items Only is un-ticked. This includes all the members physically present in the 
Revit project irrespective of whether the Work sets they lie in are active or not. 

Revit -> CADS -> Revit SCIA Engineer Link -> Options -> Export Selected Items Only 

 
 
Figure 6-2: CADS Revit SCIA Engineer Link - Export selected items only  

It is possible to specify the format of the node names to be used in the SCIA Engineer model through 
the Node format option. It is used only for export from Revit to SCIA Engineer for the first time. 

Revit -> CADS -> Revit SCIA Engineer Link -> Options -> Node Format 
 

 
Figure 6-3: CADS Revit SCIA Engineer Link – Options – Node Format  
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Structural members visible in the Revit job but linked to external Revit or other CAD files will not be 
exported, for example linking an external Revit file using the Insert->Revit Link option. 

You may choose to export only the selected members by ticking the configuration item Export Selected 
Items Only. This option could be very useful when you have a very large job but would like to analyse 
the structure in parts or would like to send updates for only a few members. 

There is no such option available when you export the job from SCIA Engineer. All structural elements 
present in SCIA Engineer will get imported into Revit. 

6.1 Log of events 

Whenever you export or import a model from Revit Structure, a log of important events is created. 
For example: 

"UC356x368x202" is mapped as "UC356/368/202" 

Doors | Doors 4      - 225505 : Not exported as this is not a structural element! 

Where 225505 is the member ID in Revit  

The log will list the different categories of items present in the model and their status. 

 

Figure 6-4: CADS Revit SCIA Engineer Link – Save Log file  

It is recommended to save the log as a *.RTF file using the Save Log button for checking and version 
control purposes. 

Items which are successfully exported or imported are marked in blue. Elements that could not be 
exported/imported or have some issues attached to it are marked in red. You can highlight the 
affected member in Revit by using Manage->Select by ID option in Revit. 

In the absence of a review manager, this is a very good option to highlight the elements marked in red 
in the log file and then take appropriate corrective action to export/import the member again.  
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Figure 6-5: CADS Revit SCIA Engineer Link – Error checking in log file 

For example in the above log file, a warning that the analytical line is not in the proper position is given 
for floor slab 227544. You can use the Manage->Select by ID option in Revit to highlight the slab and 
take the required action. 

 
Figure 6-6: Revit - Select by ID 

 
Figure 6-7: Revit - Select elements by ID  

You may then change the required member attributes and send only the selected elements using the 
option Export Selected Items Only. 

6.2 Rotation 

CADS Revit SCIA Engineer Link has developed the mapping logic based on the default cross section 
library supplied with Revit. Since the Revit family implementation logic is not uniform in Revit you 
might find that the log file shows a message such as Member rotated. This is done to ensure that the 
cross section’s handing (plane about which a cross section is mirrored) and orientation (member 
rotation about its centroid) with respect to the model are maintained in both Revit and SCIA Engineer.  

This is generally not a problem with symmetrical sections, but with asymmetrical sections you might 
find that some sections are transferred with a different handing or orientation. In these cases please 
check if the Revit family used for member mapping is a custom made Revit Family or a default one 



Revit SCIA Engineer link - Getting Started 

18 
 Copyright © Computer and Design Services Limited 

supplied with Revit. For a custom made Revit family try changing the variables which affect member 
handing and orientation and use those values which gives the correct result. Please get in touch with 
the CADS Support team if there is any issue with the cross sections library supplied with Revit. 

6.3 Eccentricity 

CADS Revit SCIA Engineer Link ensures that the member eccentricity is correctly updated during the 
model exchange between Revit and SCIA Engineer. Since the parameters required defining eccentricity 
is different in Revit and SCIA Engineer, you may find the eccentricity parameters showing slightly 
different values, but the relative position of the member with respect to the centre line is maintained. 

6.4 Support 

Foundations and Boundary conditions can be exported from Revit to SCIA Engineer either as a 
foundation block or as supports. These can be specified from the configuration option Export Revit 
Foundation. If it is set to Support then the foundations are exported to SCIA Engineer as Fixed Supports, 
otherwise the foundations are exported as Foundation Blocks in SCIA Engineer. 

 Revit -> CADS -> Revit SCIA Engineer Link -> Options 

 
Figure 6-2: CADS Revit SCIA Engineer Link - Export Revit isolated foundation as option  

If you have placed any Boundary Conditions (Point, Line or Area) in Revit then it will get exported as 
supports in SCIA Engineer with the same translational and rotational stiffness values as specified in 
Revit.  

When a job is imported into Revit from SCIA Engineer for the first time the supports are ignored and 
they do not get imported as Revit Foundataions or Boundary Conditions since CADS Revit SCIA Engineer 
Link has no information about its structural usage. But if the model is first created in Revit using the 
Boundary Conditions feature then when you edit the support condition in SCIA Engineer and import it 
back into Revit, it recognises that the supports were mapped to Boundary Conditions and will update 
it with the modified values. 

mailto:support@cads.co.uk?subject=CADS%20Revit%20Scia%20Engineer%20Link%20-%20Member%20mapping%20rule
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Where the support parameters are modified in SCIA Engineer and you do not wish them to get 
overwritten during the next export from Revit, set the configuration option Ignore Support to Yes. 

 
Figure 6-3: CADS Revit SCIA Engineer Link - Ignore support 

 Supports can be exported from Revit to SCIA Engineer only when Structural Settings in Revit is 
set to include Member Supports as shown below. 

 
Figure 6-4: Revit - Structural settings  

 
Figure 6-5: Revit - Member supports  
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6.5 Loads 

Loads modelled in Revit can be exported to SCIA Engineer and you can import them back into Revit 
after modifying them in SCIA Engineer. You may also choose to model loads in SCIA Engineer and 
import it into Revit.  

The self-weight of the structural member is not exported to SCIA Engineer from Revit. You may change 
the load values if required in SCIA Engineer using SCIA Engineer’s standard product features.  

If the user is not interested to import the generated loads, they can be ignored by choosing the “Ignore 
generated loads options to “Yes”. 

Please refer to the features list in the Help file to check how the load types are mapped between the 
two applications. 

Bi-Directional exchange of load cases and load combinations are also supported by CADS Revit SCIA 
Engineer link.  Structural Engineers may choose to ignore load cases and load combinations specified 
in Revit and handle them in SCIA Engineer separately. You can opt to ignore load cases and load 
combinations in Revit by setting the configuration option Ignore Revit Load Combination to Yes. 

 Revit -> CADS -> Revit SCIA Engineer Link -> Options -> Filters -> Ignore Load Combinations 
 

 
Figure 6-6: CADS Revit SCIA Engineer Link - Ignore load combinations option  

6.6 Composite Slabs 

Composite slabs and Roof decks modelled in Revit can be exported to SCIA Engineer and you can 
import them back into Revit after modifying them in SCIA Engineer.  

The composite slab decks are modelled in Revit as an assembly. The composite slab data are 
transferred from Revit to SCIA Engineer by reading the appropriate materials and dimensions of the 
different layers of the slab.  A separate mapping database is used to automatically map the standard 
profile sheets from Revit and SCIA Engineer.  
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Non-standard (user defined or user modified) families of profile sheets decks are not directly 
supported, but they can be exported to SCIA by mapping to the equivalent profile sheet.  

If you have the composite beam design info for the members in SCIA Engineer, the design info will be 
imported into Revit. The design info includes camber, studs and the end forces on the member. 

6.7 Virtual Joists 

Steel bar joists modelled in Revit can be exported to SCIA Engineer as virtual joists. Virtual joists are 
light-weight steel truss which consists of parallel chords and a triangulated web system. Standard 
mapping database is used to map the steel bar joists with the equivalent virtual joists. You can modify 
the virtual joists in SCIA Engineer.  

After performing the design, if you store the design info, the steel bar joists in Revit will be updated 
with the joist designation specified in the design info. The end forces are also imported into Revit as 
member forces. 

For Joists Girders, the number of joist spaces and the point load on each panel will be updated while 
importing the model from SCIA Engineer. 

6.8 Levels 

When the model is imported from SCIA Engineer, the user may specify how the levels are to be created 
in Revit. The user may optionally choose to create the levels based on the height of Stories if defined 
in SCIA or based on the elevations of slabs or based on the Z coordinates of the elements. The offsets 
on the elements in and their levels in Revit are set according the geometric position.   

6.9 Reinforcement 

CADS Revit SCIA Engineer link allows the user to import the user defined (Input) reinforcement from 
SCIA Engineer to Revit. CADS Revit SCIA Engineer link v 2020.1 also supports the import of practical 
reinforcement (Real bars converted from reinforcement design for 1D members) from SCIA Engineer 
to Revit.  The 2D reinforcements defined for the slab will be imported as “Area reinforcement” in 
Revit.  

For more details on import of reinforcement, please refer to the Help document. 

 

 


